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Introduction

Apogee’s Maestro software application provides control, routing and low-latency mixing functionality for 
Apogee hardware interfaces connected to an Apple Macintosh computer. Maestro gives you control of 
Apogee Equipment by allowing you to adjust hardware settings, configure routing between hardware I/O 
and audio software I/O, and additionally, perform low-latency mixes of hardware I/O paths and software 
outputs.

As of Maestro version 1.0, the following Apogee hardware interfaces are supported:
• Ensemble Firewire Interface
• Symphony PCI card(s) with AD16X,DA16X, Rosetta 800 or Rosetta 200 connected.

Computer requirements:
•  OSX 10.4 or above
•  Apple Macintosh PowerPC or Intel CPU, 1.0GHz or higher, 512MB of RAM required, 1GB recom-

mended
•  Supported Apogee hardware and all necessary drivers and OS X updates must be installed, tested 

and operating correctly

Installation:
To install Maestro, unzip the file (if downloaded) or insert the CD that accompanies Apogee Firewire 
and PCI hardware, and follow the on-screen instructions provided by the installer.
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Maestro consists of two main windows, Settings and Routing/Mixer from which most adjustments are made. Maestro 
also includes functionality for checking Ensemble software and firmware versions, personalizing “modifier” keys when set-
ting the mixer, and saving and recalling routing and mixer configurations. 

Settings Window – Mic Pre   (Ensemble only)

4. For a complete description of the settings displayed on the Mic Pre panel when an Ensemble is chosen under Unit   
 Select , please consult the Ensemble User’s Guide, pages 16-17.

Settings Window – Control Panel 

The contents of the Settings windows change according to the Apogee hardware connected to the computer; descriptions 
of each function below are prefaced by the Apogee interfaces to which the function is applicable.

1. Unit Select – (AD16X, DA16X, Rosetta 800/200, Ensemble) At the top left hand corner of both the Settings and 
Routing/Mixer windows is found a drop down menu to select the Apogee interface which receives the software set-
tings being made. An icon representing the selected unit appears under the Unit heading. 

 When hardware connected to a Symphony card is selected, unit names are displayed in the following format:

2. Identify Unit – (Ensemble Only) Clicking on this button illuminates all LEDs on the “active” Ensemble’s front panel, 
thereby allowing easy identification of the hardware receiving software settings. 

3. Clock Source Select - (AD16X, DA16X, Rosetta 800/200, Ensemble) This drop down menu is used to set the clock 
source of the selected interface to Internal or External. When set to Internal, the selected interface derives clock 
from an internal crystal; when set to External, clock source selection varies slightly from interface to interface as 
described below.

 Rosetta 800/200 – when set to External, the specific source (ADAT/SMUX, AES or Word Clock input) must be 
manually selected on the Rosetta’s front panel.

 AD16X – when set to External, the AD16X accepts clock from its Word Clock input.
 DA16X – when set to External, the specific source, either word clock or digital input, must be manually selected 

on the DA16X’s front panel.

  This setting is greyed out when the clock source is automatically set by the hardware system. For example, in a multi-
interface Symphony system, Clock Source Select is greyed out when any but the first hardware interface is selected 
in the Unit Select menu.

 For a complete description of the settings displayed when an Ensemble is chosen in the Unit Select menu, please 
consult the Ensemble User’s Guide, pages 14-17.

Overview

Symphony card to which 
the unit is connected

Unit model and Routing (AD-DA16X) 

Unit number
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Overview
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Overview

Settings Window – VBus

Apogee’s VBus creates virtual hardware buses to allow the routing of signals within one audio app or between different 
audio apps. For example, it’s possible in Logic Pro to record a submix of multiple audio tracks onto a new audio track 
as described below - not possible without VBus. It’s also possible to route between two audio apps by selecting a VBus 
output in the source app and a VBus input in the destination app.

 To engage VBus and specify the number of desired buses, open Apogee’s Maestro application, select one of the 
Apogee interfaces connected to the Symphony PCI card, and open the Maestro Control Panel. In the VBus drop 
down menu, select the number of virtual buses desired. As these buses don’t use much CPU power, the only reason 
to select fewer buses would be to maintain order in the I/O lists of your audio apps. Up to 32 Vbuses per Symphony 
PCI card is possible

 In order for VBus I/O to appear in your audio app’s I/O list as VBus In 1-2, 3-4, etc, it’s necessary to specify 
the use of the Symphony driver’s names in the app’s I/O list. For example in Logic Pro, open Audio>Audio 
Configuration>View>I/O Labels and Option-click on all the I/O found under the Driver’s I/O Label column.

 As an example of how to use VBus, let’s record a submix of drums onto a new stereo audio track in Logic Pro.
 
 Open Maestro and select a few Vbuses.
 In Logic’s Track Mixer, set the outputs of the individual drum audio tracks to Vbout 1/2
 Create two audio tracks (or one stereo track) and set their inputs to VBin 1 and VBin 2.
 Record-enable the new track and commence recording – the new track will record the mix of the individual drum 

tracks.

Settings Window – Performance Tuning

Performance Tuning allows the adjustment of Symphony driver buffers to take advantage of the latest Intel Macs’ 
increased CPU power. 

Set Performance Tuning to High Performance when using Symphony on an Intel Mac; this reduces buffer sizes 
and ensures the lowest latency through the Symphony system. 

Set Performance Tuning to Standard when using Symphony on G5 PowerPC Macs. Though Symphony buffers are 
set higher, latency is still quite low.

Performance Tuning is set in addition to the buffers typically found in digital audio applications. If audible clicks and 
pops are encountered, first raise the driver buffer size in the audio application. Apogee’s extensive testing of this 
driver indicates that software buffers will “run out” before the Symphony driver buffers controlled by Performance 
Tuning. If problems persist set Performance Tuning to Standard.

5
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Routing/Mixer Window

1.  Unit Select , Identify Unit – These controls, found at the top of the Input, Output and Mixer panes, are identical to 
those found in the Settings window described on page 2. 

Input Pane

 The Input Routing pane consists of an intuitive routing grid on which connections between hardware inputs and signal 
paths to software applications are made. In the software app, these connections appear as inputs. For example, 
Maestro’s default routing for Ensemble sends the hardware analog input 1 to Logic Input 1, analog input 2 to Input 2, 
and so on. It’s also possible to send one hardware input simultaneously to several software signal paths.

 Hardware inputs are represented by a row at the top of the grid while paths to software are represented by the col-
umn to the left of the grid, as depicted below. To enable a connection, position the curser over the grid at the intersec-
tion of the desired hardware input and software signal path and click on the connection box.

2.  Matrix – Signal paths to software may be configured as Mono or Stereo in this column of drop down menus. The 
Mono setting allows for the greatest routing flexibility, while the Stereo setting offers the convenience of routing sig-
nals a pair at a time. A path may be set to Off in this menu as well.

3.  Input – Signal paths may be labeled in this text box. If Matrix is set to Stereo, click on the triangle to the left of the 
Matrix menu to expand the path to two Mono paths, which may be individually labeled. 

4.  (Analog,Option,Hardware) In – This row represents the inputs available on the selected hardware.

5.  Mixer A In, Mixer B In – It’s possible to route the output of either the A or B mixer (found in the Mixer pane) back into 
the software application. For example, when hardware synths are connected to the hardware inputs of an Apogee 
interface, it’s possible to mix these synths using the Maestro mixer and record the mix in your software application by 
assigning either the Mixer A In or Mixer B In to a software path.

Input signal path: Ensemble> Maestro> Logic
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Input Pane
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Output Pane

 The Output routing pane is functionally similar to the Input pane, but used to make connections between hardware 
outputs and signal paths from software applications, as depicted below. In the software app, these connections ap-
pear as outputs.

 Hardware outputs are represented by a row at the top of the grid while paths from software are represented by the 
column to the left of the grid

1. Matrix - Signal paths from software may be configured as Mono or Stereo in this column of drop down menus. The 
Mono setting allows for the greatest routing flexibility, while the Stereo setting offers the convenience of routing sig-
nals a pair at a time. A path may be set to Off in this menu as well. 

 (Ensemble Only) Also found in this drop down menu are a list of Ensemble inputs with the suffix Direct. These selec-
tions allow the direct routing of hardware inputs to hardware outputs. For example, it’s possible to route Ensemble’s 8 
analog inputs to the optical output while routing the optical input to the 8 analog outputs. This configuration is shown 
in the lower routing page example shown at right.

2.  Output - Signal paths may be labeled in this text box. If Matrix is set to Stereo, click on the triangle to the left of the 
Matrix menu to expand the path to two Mono paths, which may be individually labeled.

3. (Analog,Option,Hardware) Out - This row represents the outputs available on the selected hardware.

Input/Output Panes : Interface-specific details

 If a connected AD16X is set to Standard routing, there will be no paths listed in the Output pane, as there is only one 
signal path (analog inputs to all digital outputs) when the AD16X is set in Standard routing. 

 When the AD16X is set in Advanced routing, the Input pane is used to route the AD16X’s analog inputs to software 
inputs, and the Output pane is used to route software app outputs to the AD16X’s AES and ADAT/SMUX outputs.

 Likewise, if a connected DA16X is set to Standard routing, there will be no paths listed in the Input pane. 

Routing Mixer Window

1

2

Output Signal path: Logic> Maestro> Ensemble

3

1a
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Output Pane
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Before describing the functions of Maestro’s Mixer pane, we now present a bit of background information concerning 
latency and Mac-based digital recording setups.

When recording with most computer-based digital audio applications, the delay between the input and output of the re-
cording system can disturb the timing of musicians recording their performance while listening to the output of the system. 
This delay, known at latency, means that the musician hears the notes he produces a matter of milliseconds after having 
produced them. As anyone who has spoken on a long distance call with echo or delay knows, relatively short delays can 
confuse the timing of any conversation, spoken or musical.

To illustrate the effect of latency, figure 1 depicts the typical signal path of a vocal overdub session. A vocalist sings into a 
microphone, which (after pre-amplification) is routed to an analog to digital converter, then to the audio software applica-
tion for recording. In the software app, the vocalist’s live signal is mixed with the playback of previously recorded tracks, 
routed to a digital to analog converter, and finally to the vocalist’s headphones. A slight delay is added at each conversion 
stage, while a much greater amount of delay occurs through the software app, resulting in the vocalist hearing his notes in 
headphones up to several milliseconds after having sung them. 

Maestro Mixer – An Overview

Figure 1



APOGEE ELECTRONICS

11

Maestro – User’s Guide

Maestro Mixer – An Overview

By modifying the signal path as illustrated in figure 2, it’s possible to provide the vocalist a headphone monitoring signal 
with a much smaller delay. First, the signal being recorded (in this case, a vocal mic) is split just after the A/D stage and 
routed not only to the software app for recording but also directly back to the hardware outputs without going through the 
latency-inducing software app; this creates a low-latency path from mic to headphones. But in order to overdub, it’s neces-
sary to mix this direct path with tracks being played back from the software app. By creating a DSP mixer in hardware, the 
required mixing may be accomplished. Indeed the mixing “engine” of Maestro’s Mixer  “resides” on DSP found in Apogee 
hardware; the actual Mixer pane may be thought of as a software remote control for this DSP hardware mixer.

Before this theoretical examination of low-latency mixing discourages you from ever recording again, here are a few 
simple guidelines for working with a software app (in this case, Apple Logic Pro) and Maestro’s mixer.

1. Configure Logic Pro so that the track to which you’re recording will mute 
when Record is engaged but will play back when Record is disengaged (even 
if the track is record-enabled). Thus, when actual recording is taking place the 
performer only hears the low-latency path in his headphones, but hears play-
back of the track (for punching in) before and after Record is engaged. This is 
accomplished quite simply by unchecking the Software Monitoring box in the 
Audio Hardware and Drivers page.

2. Set both the Maestro and Logic channel faders through which the recorded 
signal is passing to 0 dB, to avoid changes in level between recording and 
playback. Rather than adjust these faders, adjust playback faders to achieve 
the desired balance between playback and the signal being recorded. Also set 
the DAW Return and Maestro Main Output faders at 0 dB. By “zeroing out” the 
Maestro mixer and making all level changes in the software app mixer where 
practicable, operation is quite a bit more straightforward.

Figure 2
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Mixer Pane

As described in the previous section, the Maestro mixer serves to blend hardware inputs with software app playback, and 
route the mix directly to hardware outputs, as depicted below.

1.  Mixer Select (A-B) –  This drop down menu selects between the two available mixers per hardware interface.

2.  Input channels –  These channels provide the functions described below for controlling inputs to the mixer. Hard-
ware inputs of the selected interface (under Unit Select) are the source for these input channels. The mixer always 
displays 18 inputs; if the selected device is equipped with less than 18 inputs, the unused mixer channels are greyed 
out. 

3. Pan – This slider pans the input signal between the left and right sides of the Mixer Main Output.

4. Pan value window – The pan value (where full left is designated <64, center is <0> and full right is 64>) is displayed 
in this window.

5. Level fader – This slider set the level at which the input signal is mixed to the Mixer Main Output.

6. Level value window – The Level value (between “Muted” and +6) is displayed in this window

7. Meter – This bargraph style meter displays the pre-fader input level.

8. Mute – This button mutes the input channel.

9. Solo – This button solos the input channel, thereby muting all channels whose Solo buttons are not engaged.

Routing/Mixer Window

1
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Routing/Mixer Window

10. DAW Return – This stereo input provides level control, metering and mute/solo functions for the DAW Return signal, 
the mix of playback tracks from the software app. To route the software app mixer’s outputs to the DAW Return input,  
set the DAW Return drop down menu to the same output as the software app mixer output. **

11. Main Output – This stereo channel provides a level fader, metering and a routing selection drop down menu for 
controlling the stereo output of the mixer. The Main output drop down menu selects the hardware output to which the 
Main Output is routed. **

** As a general rule, the DAW Return and Main Output drop down menus will be set to the same hardware output. In ef-
fect, the Maestro mixer is inserted between the software app mixer output and the physical hardware output.

(Symphony only) When multiple hardware interfaces are connected to a Symphony card, the outputs of all the interfaces 
connected to one Symphony card are listed in this drop down menu. For example, consider a system consisting of 
2 AD16Xs and 2 DA16Xs connected to one Symphony card and 2 Rosetta 800s connected to a second Symphony 
card. If either AD16X is selected under Unit Select, all DA16X outputs are listed under the Main Output menu, while 
if either Rosetta is selected all Rosetta outputs are listed. Symphony allows you to mix signals across hardware de-
vices attached to the same card, but it’s not possible to mix the inputs of hardware connected to one Symphony card 
to outputs of hardware connected to other Symphony cards.
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Maestro – Menu by Menu

Maestro:
Maestro> About Maestro
 Selecting this menu item opens the panel shown below, which indicates the versions of Mae-

stro, Maestrolink software and Ensemble firmware. 

Maestro> Preferences
 Selecting this menu item opens the Preferences panel, in which mixer control actions may 

be defined.
 

Maestro> Preferences> Rotary Controls
 Mouse motion – This selection defines the motion of the 

mouse required to adjust rotary controls such as Ensemble 
Mic Pre gain.

 Fine adjust key – This selection defines the modifier key to 
hold down in order to make fine adjustments to any rotary 
control. 

Maestro> Preferences> Fader controls
 Fine adjust key - This selection defines the modifier key to 

hold down in order to make fine adjustments to any fader con-
trol. 

 0dB key – This selection defines the modifier key to hold 
down in order to set the fader to 0 dB when clicking in the level 
value window.

 Ungroup faders - This selection defines the modifier key to 
hold down in order to adjust one side of the Stereo DAW Re-
turn and Main Output faders.

 Mute/Solo all - This selection defines the modifier key to hold  
down in order to engage all Mutes or Solos when clicking on 
the Mute or Solo buttons.

Maestro> Preferences> Pan Controls
 Fine adjust key - This selection defines the modifier key to 

hold down in order to make fine adjustments to any pan con-
trol.

 Center - This selection defines the modifier key to hold down 
in order to set the pan control to <0>, or center, when clicking 
in the pan value window.
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Maestro – Menu by Menu

Maestro> Hide Maestro
 Selecting this menu item hides the Maestro application.
Maestro> Hide Others 
 Selecting this menu item hides all other open applications.
Maestro> Show All
 If Hide Others has been previously selected, selecting this menu item reveals all open 

apps in the Finder.
Maestro> Quit Maestro 
 Selecting this menu item closes the Maestro program.

File:
File> Open
 Select this menu item to navigate to a previously saved Maestro configuration file and 

open it.
File> Open Recent 
 Select this menu item to re-open a recently opened Maestro configuration file.
File> Close Window 
 Select this menu item to close the “active”, or up-front, window.
File> Save 
 Select this menu item to save the current settings of all windows.
File> Save As
 Select this menu item to save the current settings of all windows as a newly named 

file.

Tools:
Tools> Settings
 Selecting this menu item opens the Settings window
Tools> Routing Mixer
 Selecting this menu item opens the Routing/Mixer window
Tools> Refresh Connections
 Selecting this menu item re-scans computer connections for connected Apogee hard-

ware.
Tools> Reset Mixer
 Selecting this menu item resets all mixer faders to Muted and all Pan sliders to <0>, or 

center.
Tools> Reset Routing
 Selecting this menu item resets the Input and Output panes to a “pass through” con-

figuration, where hardware and software I/O are connected on a one to one basis.

Window:
Window> Minimize
 Selecting this menu item minimizes the up front window to the OS Dock.
Window> Zoom
 Selecting this menu item maximizes the size of the active Maestro window.
Window> Bring All to Front
 Selecting this menu item places all Maestro windows in front of other applications’ 

windows.
Window> Settings
 Selecting this menu item brings the Settings window to the front of the Finder.
Window> Routing/Mixer 
 Selecting this menu item brings the Routing/Mixer window to the front of the Finder. 
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